ODSeasyNet - Systemanforderungen

ODSeasyNet ist eine Browserapplikation, daher sind die Systemanforderungen anders als bei ODSeasy. ODSeasy und ODSeasyNet sollten jedoch auf dem gleichen Server installiert werden, um eine optimale Zusammenarbeit zu gewährleisten.

Anforderungen an den Server

  • Installlierte, in der Support-Chain von Microsoft™ befindliche, MS-Windows™ Server Software (Veraltete Windows-Server Versionen werden von asthenis nicht aktiv supported)
  • Internet Information Services (IIS) ab Version 7 oder höher
  • .NET Framework Version 4.5 oder höher
  • Das Verzeichnis /BIN und die Datei web.config müssen vom Virenscan ausgeschlossen werden
  • Serverhardware virtuell oder dedicated
  • 16 GByte RAM
  • 100 GByte Festplatte (je mehr desto besser)
  • Core-Prozessor der neueren Generation

Anforderungen an die Clients

  • Betriebssystem egal (Windows, Mac-OS, Linux, iOS, Android, Windows-RT usw.)
  • HTML5 fähigher Browser der neueren Generation (Edge Chromium, Firefox , Safari, Opera, Chrome usw.)
  • Java-Script muss zugelassen sein
  • Bildschirmauflösung von idealerweise 1980 x 1020 Bildpunkten
  • PDF-Viewer
  • MS-Excel und MS-Word werden von ODSeasyNet unterstützt, falls auf dem Client installiert

ODSeasyNet verwendet asynchrone Datenbankabfragen (AJAX) und komfortable, formularabhängige Eingabemasken. Dies ist ohne sogenannte Java-Script Frameworks nicht möglich. Wir verwenden die weit verbreitete Open Source Bibliothek "jQuery". Für die serverseitige Programmierung wird ausschliesslich asp.net verwendet. ODSeasyNet ist eine sogenannte "Rich Internet Application", der Einsatz von Java-Script ist hierzu eine zwingende Voraussetzung.

Das Hosting innerhalb der eigenen Einrichtung wird von uns ausdrücklich empfohlen, idealerweise auf demselben Server, auf dem ODSeasy bereits läuft (ODSeasy ist jedoch keine Voraussetzung für ODSeasyNet).

Wir empfehlen, auf Grund unserer umfangreichen Tests, generell die Nutzung von Firefox ab Version 20, Chrome oder Edge Chromium. Der Internet Explorer wir von uns, auf Grund von Sicherheitsrisiken, nicht mehr unterstützt. Microsoft hat den Support für den Internet-Explorer (IE) Mitte 2022 eingestellt. Daher können wir die einwandfreie Funktion von ODSeasyNet auf diesen Browsern nicht gewährleisten und auch keinen Support zur Nutzung von ODSeasyNet mit diesem Browser mehr anbieten.

Für die Nutzung von ODSeasyNet unter https (SSL) muss ein gültiges SSL-Zertifikat vom Kunden bereitgestellt werden.